EMOD Setup

Institute for Disease Modeling

Required packages, from PrepareLinuxEnvironment.sh. Link libmpich10 paths to current versions of the library—maybe this will work.

apt-get -qq update
apt-get install libboost-mpi-dev scons mpich libmpich-dev xauth git-lfs pigz
conda install pyyaml xlrd

cd /usr/lib/x86_64-linux-gnu
ln -fs libmpichcxx.so libmpichcxx.so.10
ln -fs libmpich.so libmpich.so.10
ln -fs libopa.so libopa.so.1
ln -fs libmpl.so libmpl.so.1

Clone EMOD, and untar the input data saved in the Appendix.

git clone https://github.com/InstituteforDiseaseModeling/EMOD
cd EMOD
git checkout v2.18.0

cd /
pigz -dc EMOD-InputData.tar.gz | tar -xf -

Link input data.

ln -s /EMOD-InputData /EMOD/InputData

Download the executable file, set +x.

cd /usr/local/bin
wget https://github.com/InstituteforDiseaseModeling/EMOD/releases/download/v2.18.0/Eradication
chmod +x Eradication
© 2018 Nextjournal GmbH